MyLeague - MyLeague.com is experiencing website issues – Incident details

All systems operational

MyLeague.com is experiencing website issues

Resolved
Major outage
Started 5 days agoLasted less than a minute

Affected

MyLeague Website

Operational from 10:00 PM to 10:00 PM

MyLeague.com

Operational from 10:00 PM to 10:00 PM

MyLeague Account Login

Operational from 10:00 PM to 10:00 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    We recently have been having site issues connected to extra traffic being received from dozens of AI companies crawling the site. It has arrived in unpredictable patterns and volume which means our normal automatic scaling was not set up to handle these surges well. Today we rolled out fixes that should help prevent this in the future. This incident has been resolved.